Arduino Library für Jeti EX Eigenbau-Telemetrie

09 Okt 2017 11:26 #283 von sierra_uniform
Hallo Ingmar,

ja ich verwende diese Bibliothek, Version ist die 1.04.

Gruß SU

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

09 Okt 2017 14:53 #284 von IG-Modellbau
Hallo SU,
habe gerade in die V1.04 geschaut, ist alles richtig, es wird entweder ein Tastencode, oder ein Alarm, oder das EX-Frame gesendet.
Mit dieser Priorität.
Somit also von Seiten der JetiEx-Bibliothek alles OK.

Nein, Du kannst keinen EX-Alarmwert und den Morse-Alarm gleichzeitig verwenden.
Das schließt sich, gemäß Jeti-Protokoll, gegenseitig aus.
Du musst die Morse-Alarme, so alle ein bis zwei Sekunden dazwischen streuen.

Ingmar
Folgende Benutzer bedankten sich: sierra_uniform

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

09 Okt 2017 16:08 #285 von sierra_uniform

IG-Modellbau schrieb: Hallo SU,
Nein, Du kannst keinen EX-Alarmwert und den Morse-Alarm gleichzeitig verwenden.
Das schließt sich, gemäß Jeti-Protokoll, gegenseitig aus.
Du musst die Morse-Alarme, so alle ein bis zwei Sekunden dazwischen streuen.

Ingmar


Hallo Ingmar,

erst mal vielen Dank für Deine Mithilfe:)
Ich habe es nach Deinem ersten Post ja so versucht, dass ich jeweils für sich alleine 19 mal die EX-Werte und anschließend 1 x den Morsealarm (auch für sich alleine) geschickt habe. Einen EX-Alarmwert habe ich gar nicht losgeschickt. Ob man das kann, weiß ich nicht. Der Alarm wird ja im Sender definiert und ist damit unabhängig vom Sensor - oder liege ich da falsch.

Viele Grüße SU

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

09 Okt 2017 16:34 #286 von IG-Modellbau
Hallo SU,
mit EX-Alarm meinte ich den Sensorwert, der dann im Sender zum Alarm führt.
Hast das also alles richtig gemacht.
Mit 19 zu 1 kommen da die Alarme nicht zu oft?
Ich hätte eher auf 50 zu 1 getippt. Oder sogar 100 zu 1, habe da aber noch keine Erfahrung.
Kannst ja mal probieren wie oft dann der Alarm am Sender ankommt.

Ingmar

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

10 Okt 2017 13:28 #287 von sierra_uniform
Hallo Ingmar,

Problem ist gelöst. Traue mich fast nicht es zu sagen: War wohl ein typischer Anfängerfehler. Hatte var++ und ++var verwechselt. Dadurch kam's nur noch zu Dauerfeuer des Morsealarms. Jetzt ist nur noch jede 2000. Übertragung ein Morsecodealarm. Zusätzlich habe ich 3 msek. Pause nach jedem Messzyklus eingebaut. Das führt nun alle ca. 9 Sekunden zu einer Wiederholung der Sprachausgabe des Morsecodealarms.
Nochmal vielen Dank für Deine Hilfe!!!

Gruß SU

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

10 Okt 2017 14:10 #288 von IG-Modellbau
Hallo SU,
kleine Ursache, große Wirkung...
Freut mich, das es nun funktioniert!

Ingmar

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 0.125 Sekunden

Impressum