OpenXSensor für Jeti

11 Dez 2017 11:05 #145 von onki
Hi Volker,

das stimmt nicht ganz. Man kann über die JB Emulation die Flussmengen zurücksetzen und auch kalibrieren.

Gruß
Onki

Gruß aus dem Nordschwarzwald
Rainer aka Onki
www.onki.de
gepostet unter Verwendung von 100% recycelter Elektronen.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

11 Dez 2017 12:46 #146 von VOBO
Danke für den Hinweis Onki.

Ich habe bisher nur Varios, Spannungs- und Strommessungen gemacht.
Da ist mir eine Schnittstelle zur Jetibox nicht bekannt.

Gruß Volker

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

17 Dez 2017 22:36 #147 von Frank DS16
Hallo Zusammen,
mein erster oXs-Sensor ist fertig und funktioniert (zumindest auf dem Schreibtisch).
Ich habe eine Platinen von Marcel Bardehle (antimaster ät gmx.de) genutzt, da wird der Mini gleich angedockt. Die Platinen sind eigentlich für HOTT gemacht …
Ich arbeite mit 3,3 V Arduinos. Die BEC-Spannung liegt an RAW. Der 758 wird mit den 3,3 V des Arduinos betrieben.
Wichtig ist (steht schon an einigen Stellen): Der 758 liefert bei 3,3 V Versorgungsspannung (statt 5,0V) entsprechend kleinere Spannungen als im Datasheet angegeben (Verhältnis 3,3 / 5,0) in Abhängigkeit des fließenden Stroms. Auch die Offset-Spannung ist im Verhältnis 3,3/ 5,0 kleiner als 0,6V. (Steht alles im Datenblatt … ich weiß … nun …)
In Zukunft möchte ich gerne die interne 1,1V Referenz des Arduino nutzen. Vorerst nutze ich die 3,3V des Arduino als Referenz.

Also es scheint alles zu funktionieren, aber ein paar Fragen habe ich doch …
Frage 1:
Muss ich zwei Spannungen definieren, wenn ich Spannung und Strom (gemessen über eine Spannung) messen will?
Ja, oder? Also:
// ***** 2.4 - Jeti data *****
#define VOLTAGE_SOURCE VOLT_1 , VOLT_2
Ist das richtig? Es funktioniert so jedenfalls … (auf dem Schreibtisch)

Frage 2:
Ist es richtig, dass in der config_basic.h
#define NUMBEROFCELLS 1
steht, wenn ich nur die Gesamtspannung übertragen will? Eigentlich will ich ja keine Einzelzelle überwachen …
Es funktioniert so jedenfalls … (auf dem Schreibtisch)


Frage 3:
In der config_:advanced.h setze ich:
#define REFERENCE_VOLTAGE 3300 // set value in milliVolt; if
da ich den 3,3V Arduino nutze? Ist das richtig? Es funktioniert so jedenfalls … (auf dem Schreibtisch)
Anhang:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

18 Dez 2017 10:50 - 18 Dez 2017 11:04 #148 von VOBO
Zu Frage1:
Es reicht einen Wert auszuwählen, der 2. stört nicht, da er ignoriert wird.

Im Prinzip bräuchte hier auch garnichts zu stehen, da du ja formal eine Einzelpannungsmessung mit nur einer Zelle durchführst (numberofcells=1).
Dabei ist zwingend die Belegung ab Volt_1.
Du erhältst dann die Gesamtspannung des Flugakkus automatisch mitgeliefert.

Gruß Volker

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

19 Dez 2017 21:01 - 19 Dez 2017 21:02 #149 von Frank DS16
Hallo Zusammen!
In den letzten Tage habe ich mich etwas in Eagle eingearbeitet und habe ein Platinenlayout für einen Spannungs-/Stromsensor (auf Basis 758) erstellt.

Bevor ich das Layout auf den Weg Richtung China schicke, würde ich mich freuen, wenn von Euch mal einer drüber schauen kann. Geht sicher alles besser; es ist aber nicht mein Anspruch es perferkt zu machen. Aber natürlich möchte ich auch nur ungern lange auf Post warten und dann Schrott zurück bekommen ...

Wer Interesse hat sich das mal anzuschauen wendet sich einfach an
fwitte et gmx punkt net

Es ist noch nicht reif hier eingestellt zu werden. Z.B. könnte man es noch kleiner machen ...

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

01 Jan 2018 23:31 #150 von marswolf
Hallo,
Ich komme leider nicht weiter, nicht mal über Google Suche. Ein einfaches oXs Vario mit GPS habe ich wunderbar hinbekommen. Jetzt wollte ich eine TEK Düse nachrüsten. Mein 1. Baro ist ein MS5611 als GY-63. Mein 2. ebenfalls. Der 1. Baro geht über I2C 0x77. Das sei quasi schon so standardmäßig bei den GY-63 Chinaboards eingestellt. Den zweiten Baro muss man auf 0x76 stellen. Laut oXs description bei diesem 2. Baro VCC (oder VDD) verbinden mit CSB (was CE Chip enabled sein soll). Muss ich da einfach nur eine Brücke ziehen zwischen VCC und CSB? Viele Anleitungen die ich fand bezogen sich auf drotek GY-63, der Jumper hierfür zum Löten aufweist. Meine haben dies nicht. Um eine kurze Hilfestellung wäre ich sehr dankbar. Liebe Grüße, Marcel

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 0.124 Sekunden

Impressum