Throttle cut for electric motors on DS-14

18 Nov 2017 15:32 - 18 Nov 2017 15:37 #1 von wiff
Hallo Claus,
habe Dein ThrotCut Lua Script auf meiner DS-14 ausprobiert. Es funktioniert SUPER :P
Eine Kleinigkeit ist mir aufgefallen:
Beim Text "Throttle cut active" sieht das Symbol, das danach kommt komisch verpixelt und nicht erkennbar aus.

Im Code steht: lcd.drawImage (140,120,":okBig")
okBig ist ein "Default system image"
Muss man bei der DS-14 etwas anderes aufrufen/initialisieren ?

Herzliche Grüsse und vielen Dank für Deine Arbeit
Wolfgang

Wolfgang
Anhang:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

18 Nov 2017 16:13 #2 von ClausT
I know - my DS16 tester have reported the same.
Fixing it right now, hang on :-)

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

18 Nov 2017 16:43 #3 von ClausT
Hi Wolfgang,
New version uploaded, please test :-)

For 14/16 transmitters YES or no will be displayed instead of the graphics on 24.

github.com/ClausTonnesen/JetiLua-ThrottleCut

Thank you for your feed back, glad you like it.

/Claus
Folgende Benutzer bedankten sich: wiff

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

18 Nov 2017 17:00 #4 von wiff
Hi Claus,
it works - thanks for the superfast fix - excellent job!

BTW: Hope that Jeti will fix that - makes it harder to write portable code ...

All the best
Wolfgang

Wolfgang

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

19 Nov 2017 13:20 #5 von PHO
Was genau kann man mit dem Skript lösen, das die DS/DC nicht bieten würde?
Wäre ein logischer Schalter auf dem Motor AUS in den Modelloptionen nicht genau das Gleiche?

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

19 Nov 2017 13:34 #6 von wiff
Das hab ich auch schon probiert, aber ich hab' keine schlaue Lösung gefunden.
Was wäre Dein Vorschlag?

Gruss, Wolfgang

Wolfgang

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 0.105 Sekunden

Impressum