Besondere Mischer programmieren

06 Sep 2017 13:26 #1 von yachty
Hallo und guten Tag,

seit einem guten halben Jahr bin ich stolzer und zufriedener Besitzer einer DS16 mit dem aktuellen update auf 24 Kanäle. Ich habe den Sender mit den entsprechenden Schaltern bereits auf meine Bedürfnisse als Yacht-Modellbauer angepasst, und auch zwei Modelle, eines mit einem einfachen Singleschrauben-Antrieb, und eins mit einem Doppelschrauben-Antrieb - auch mit den zugehörigen Mischern, programmiert.

Nun bin ich beim Bau und der RC-Planung eines recht großen Mega-Yacht Projektes, diesmal aber mit zwei Wasserstrahl-Antrieben. Und dies scheint nun programmiertechnisch eine echte Herausforderung zu werden, und so hoffe ich hier von den Jeti-Profis vielleicht einige Tipps zu bekommen.

Zunächst zur Erklärung kurz etwas zur Technik des Wasserstrahl-Antriebs. Der Antriebsmotor läuft grundsätzlich nur vorwärts (also in eine Richtung!), da zum Rückwärtsfahren mittels Servo eine Klappe über die Ausstoßdüse des Wasserstrahls gefahren wird. Somit braucht man zur Steuerung der Motoren lediglich einen Steller ohne Rückwärtsfunktion - also einen bzw. zwei Flugregler! Die Fahrfunktionen der Modellyacht sind im Sender folgendermaßen belegt:

Kanal 1 und 3: Gasfunktion bis Regler - je ein Steller
Kanal 2: Lenkung beider Steuerdüsen mittels V-Kabel auf 2 Servos
Kanal 4: Bugstrahlruder mittels vorwärts/rückwärts Steller
Kanal 5: Rückwärtsfahrklappe steuerbord mittels Servo
Kanal 6: Rückwärtsfahrklappe backbord mittels Servo

Ich möchte nun zum schnellen Fahren mittels Mischer Kanal 3 zu Kanal 1 mischen, womit ich dann wie bei einer modernen Joystick-Steuerung (heute bei vielen großen und vor allem schnellen Yachten üblich) Lenkung und Gas auf dem rechten Kreuzknüppel habe. Das ist soweit kein Problem, ich hab das bei meiner Yacht mit Doppelschrauben-Antrieb bereits so verwirklicht. Beim langsamen Fahren im Hafen möchte ich die Motoren einzeln steuern können!

Nun aber kommt die Herausforderung: Trotz Flugsteller soll die Nullposition der Kreuzknüppel in der Mitte verbleiben. Beim Rückwärtsfahren hätte ich gerne auch das passende Fealing der Finger auf dem Sender, also möchte ich die Knüppel nach unten (hinten) bewegen, und dabei sollen erstens die Motoren anlaufen (also vorwärts B) ), und zweitens die Servos der Rückfahrklappen jeweils dazu gemischt werden können.

Dafür habe ich bisher noch keine wirkliche Lösung gefunden, ich kann aber sagen, dass ein Kollege von mir genau diese Funktionen mittels Mischer in seiner MC-32 verwirklicht hat, und zwar mit den gleichen Antriebs- und RC-Komponenten !!! Leider läßt sich die Programmierung nicht so einfach von Graupner/JR auf Jeti übertragen, da die Bedienung bzw. Software wohl eine völlig andere ist.

Folgendes möchte ich noch hinzufügen: Ich weiß, das es fertige Schaltbausteine für diese Funktion gibt. Diese werden zwischen Empfänger und Steller geschaltet, und auch das Servo für die Rückfahrklappe wird an diesem Baustein angesteckt. Dieser Baustein hat jedoch zwei gravierende Fehler bzw. Nachteile:
1. wird das Servo für die Klappe beim Rückwärtsfahren (zurückziehen des Knüppels) ausschließlich voll nach unten gefahren, es gibt also keinerlei Zwischenstellung. Diese wird aber zum besseren Manövrieren benötigt, und
2. ist der Baustein lediglich für 4,8 Volt ausgelegt. Man kann also nicht mal mit 6 Volt Empfänger-Spannung fahren. Das ist mir zu wenig!

Nun hoffe ich sehr, dass ich hier den ein oder anderen Tipp für die Lösung meiner Programmierprobleme bekommen kann.
Ich danke allen, die sich die Zeit genommen haben, meinen ausführlichen Text bis hierhin zu lesen - ich hoffe er ist verständlich.

Mit meinen besten Grüssen aus Solingen,
Bert

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

06 Sep 2017 17:46 - 06 Sep 2017 17:48 #2 von sunbeam
Hallo!

Was mir spontan einfällt: Die Funktionskurve für die Motoren könntest du dir als ein "V" programmieren anstatt der diagonalen Linie von links unten nach rechts oben. Dann würde, ausgehend von der Knüppelmittelstellung (was der unteren Spitze des V entspricht), Gas immer vorwärts ausgegeben werden, ganz egal, ob du den Knüppel nach oben (= rechter Ast des V) oder nach unten (= linker Ast des V) bewegst.
Über Flugphasen und bspw. Dual Rate oder auch eine neutralisierte Funktionskurve, die kein Gas ausgibt, könntest du dir diese Motoransteuerung schaltbar machen. Damit wäre sichergestellt, dass du entweder nur vorwärts mit dem vollen Knüppelweg auf dem linken Knüppel oder nur vorwärts/rückwärts auf dem rechten, neutralisierenden Knüppel fahren kannst - und nicht beides gleichzeitig ;-)

Auf dem rechten Knüppel könntest du dir auf dem unteren Knüppelweg im Menü Sticks- und Schalter-Setup (oder so ähnlich) einen Schaltpunkt setzen, mit dem du die Klappe betätigst. Mit einem Mischer "Gas auf Klappe" und einer entsprechend angepassten Mischerkurve sollte es auch funktionieren.

Gruß, Kai

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

06 Sep 2017 20:33 #3 von yachty
Hallo Kai,

danke für die Tipps, vor allem der mit der Funktionskurve. ich werds morgen mal testen, und dann berichten.

Beste Grüsse,
Bert

P.S. Auf dem Foto ist das Vorbild der Yacht zu sehen, in welche die Technik hinein soll. Das Vorbild ist 33m lang, und 100 km/h schnell. Mein Modell entseht im Maßstab 1:20, und bekommt zwei bürstenlose Plettis.
Anhang:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

06 Sep 2017 21:14 #4 von sunbeam
Hallo Bert,

schönes Boot, viel Spaß damit!

OT: Nimm gute Regler, die Jets können ganz schön Strom ziehen, wenn man Gas gibt ;-)

Gruß, Kai

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

07 Sep 2017 10:14 - 07 Sep 2017 11:02 #5 von yachty
Guten morgen Kai,

schön das dir mein Boot gefällt. Zum Antrieb: Herr Maier von Plettenberg hat mir an Hand der Modelldaten, Rumpfform, des max. Gewichtes und der Antriebe die Antriebs-Komponenten zusammengestellt bzw. empfohlen: Zwei mal HP 370BM/30 A2 "S" mit je einem Schulze Regler an 8S LiPo´s. Das sollte wohl funktionieren.

Zum Programmieren. Ich bin gerade ein wenig am Verzweifeln, denn prinzipiell funktioniert der Weg über die Funktionskurve, aber leider nur auf Kanal 1, also für den Steuerbord-Motor. Ich hab trotz intentiver Testerei bisher keine Lösung finden können, und bin nun ziemlich ratlos (zugegebenermaßen bin ich aber auch noch Anfänger fürs "Jeti-Programmieren"). Der Sender liegt zur Zeit mal wieder am Ladekabel......
Im Einzelnen hab ich folgende Probleme:

Kanal 1 - Steuerbordmotor: Die V-Prgrammierung funktioniert, aber je weiter ich den Minusausschlag (linker Teil des V´s) Richtung 0% nach oben schiebe, desto weiter wandert die Servomitte nach rechts ab. Momentan steht die Rückwärtsfahrt auf 80% (linke V-Hälfte), wobei die Servomitte bei 30% liegt. Kann man das nicht korrigieren? Ich hatte gedacht, das ginge mit dem Servo Balancer - war aber nix. Die Servomitte in den Servoeinstellungen zu verschieben bzw. auszugleichen kann ja nicht Sinn der Sache sein!
Kanal 2 - Backbordmotor: Die V-Programmierung funktioniert nicht. Ich habe genau wie auf Kanal 1 in den Servoeinstellungen das Max. und Limit Negativ auf 0% gesetzt. Wenn ich dann in der Funktionskurve die linke Minusseite wieder nach oben verschiebe, wird der Servoausschlag immer geringer, bis sich ab der Mitte, also 0% garnichts mehr bewegt.

Ich hab übrigens zum Testen auch mal ein Servo an beide Kanäle angesteckt. Der Ausschlag der Servos entspricht exakt dem virtuellen Ausschlag auf dem Senderdisplay! Nun bin ich absolut ratlos :( :( :(

Übrigens habe ich beim Anlegen des Modellspeichers nur einen Motor ohne Rückwärtsfahrt angelegt, da ich beim ersten Versuch mit zwei Motoren dann bei der Vergabe der einzelnen Kanäle den zweiten Motor nicht programmieren bzw. wiederfinden konnte. Auch dafür hab ich trotz Sucherei keine Lösung gefunden. Übrigens ist es für die oben geschilderten Probleme egal, ob in den Grundeinstellungen für den Motor nur vorwärts oder vorwärts/rückwärts gewählt wird - hab beides ausprobiert, und nichts hat sich geändert.

Soviel zum erfolglosen Programmieren. Ich hoffe du (oder natürlich auch ein anderer Kollege) hast einen weiteren Rat für mich, da ich mit meiner Weisheit am Ende bin.
Ich wünsche allerseits einen schönen Tag,
Bert

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

07 Sep 2017 11:16 - 07 Sep 2017 11:19 #6 von w.w.

yachty schrieb: ... Der Sender liegt zur Zeit mal wieder am Ladekabel......


Dann kannst Du trotzdem weiter experimentieren.

Sollen beide Motoren unabhängig voneinander gesteuert werden oder synchron?
Soll die Schubumkehr ebenfalls getrennt für beide Antriebe aktiviert werden?

Gruß Wolfgang

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 0.113 Sekunden

Impressum