Einzustellender Wertpringt von selbst in den nächsten Eintrag

25 Okt 2017 11:23 #1 von sunbeam
Hallo!

Mir ist folgendes aufgefallen: Wenn ich in den Servoeinstellungen "Max negativ" verändere, springt die Eingabe automatisch zu den Einstellungen von "Max positiv".

Das Verhalten ist modellspeicherübergreifend reproduzierbar für folgende Fälle: "Max Positiv" steht auf einem bestimmten Wert, z.B. "+150" (wie im Video) oder auch "+100" oder halt irgendein anderer Wert. Wenn ich nun "Max Negativ" auf einen vom Betrag her gleichen Wert einstelle, also "-150" oder "-100" und erhöhe, springt die Eingabe von "Max Negativ" automatisch zu "Max Positiv".

Für die genannten Beispiele bedeutet das: Erhöhe ich den Wert von "Max Negativ" von "-150", springt die Eingabe etwa bei "-139" zu "Max Positiv". Oder das andere Beispiel: "Max Positiv" steht bei "+100" und "Max Negativ" bei "-100"; erhöhe ich den Wert "-100", springt die Eingabe bei etwa "-81" zu "Max Positiv".

Dieses Verhalten lässt sich für alle analogen Konstellationen reproduzieren.

Mache ich einen Gedankenfehler, oder liegt hier ein kleiner Bug vor? Könnt ihr das Verhalten ebenfalls nachstellen?

Hier der Link zum Video:

www.dropbox.com/s/6ihxaansnzu0afp/20171025_105405.mp4?dl=0

Gruß, Kai

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

25 Okt 2017 11:24 #2 von sunbeam
....ups :-) Kann vielleicht einer der Mods den Titel korrigieren ;-) ? Da war ich wohl zu schnell beim Tippen; es soll natürlich heißen "Einzustellender Wert springt..." :-)

Danke & Gruß
Kai

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

25 Okt 2017 11:45 #3 von wstech
Hallo Kai,
ist hier an DC-24 ist das auch so. Aber nur bei Drossel und wenn der Geber in der Mitte steht, oder?

Mit freundlichen Grüßen
Wolfgang
www.wstech.de

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

25 Okt 2017 12:40 #4 von MichaFranz
Hallo,

Sachen gibt es...Bin ich froh kein Programmierer zu sein.

Ich habe es gerade mit meiner DC16 4.23 probiert.Nur wenn der Drosselknüppel in der Mitte steht tritt der Fehler auf.Den Knüppel aus der Mitte und das Problem ist beseitigt.:silly:

Micha

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

25 Okt 2017 13:09 #5 von sunbeam
Hallo!

Tatsächlich, nur wenn er in der Mitte steht bzw. nicht ganz an den Endpunkten.. Dann wird das ggf. auch erklärbar, denn ich kann beim Einstellen der Werte den Fokus mit dem Gasknüppel verschieben. Das entspricht dann dieser automatischen "Richtungswahl" beim Einstellen von Werten, wenn man nicht weiß, in welche Richtung der Geber für positive bzw. negative Werte bewegt werden muss.

Gruß, Kai

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 0.171 Sekunden

Impressum