Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:
  • Seite:
  • 1

THEMA: Transmitter TU2 -> Problem mit Pulsdauern

Transmitter TU2 -> Problem mit Pulsdauern 21 Dez 2019 08:47 #1

  • Jasson
  • Jassons Avatar Autor
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Beiträge: 5
  • Dank erhalten: 0
Guten Morgen Forum,

ich habe ein Problem mit meinem Transmitter TU2, Firmware 3.03
Er akzeptiert keine Pulslängen länger als 1,9ms. Ich habe das mit einem Oszilloskop ausgemessen.

Habe im Manual keinen Menupunkt gefunden, mit dem sich das einstellen lässt.

Kann man die akzeptierten Pulslängen einstellen, oder ist das einfach so?

viele Grüße!

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Transmitter TU2 -> Problem mit Pulsdauern 12 Feb 2020 17:14 #2

  • nichtgedacht
  • nichtgedachts Avatar
  • Besucher
  • Besucher
Hi,

was passiert denn, wenn Du mit 2 ms ansteuerst?

Gruß
Dieter

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Transmitter TU2 -> Problem mit Pulsdauern 12 Feb 2020 17:25 #3

  • ahahn
  • ahahns Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Beiträge: 85
  • Dank erhalten: 40
Hast du eventuell einen Screenshot?
Beim PPM Summensignal wird die Zeit zwischen zwei gleichen Flanken gemessen.
Also normalerweise zwischen den fallenden Flanken, d.h. die Pulsbreite als solche ist egal. Meist ist die Pause konstant 390 us (Graupner/JR). So gesehn würden deine 1.9ms tatsächlich 2.29 ms bedeuten.
Nur eine Vermutung.

lg
Alois

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Letzte Änderung: von ahahn.

Transmitter TU2 -> Problem mit Pulsdauern 06 Mai 2020 08:55 #4

  • Jasson
  • Jassons Avatar Autor
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Beiträge: 5
  • Dank erhalten: 0
"was passiert denn, wenn Du mit 2 ms ansteuerst?"
Wenn ich einen Puls größer 1,9ms erzeuge, gibt das Sendemodul den Warnton für inkorrektes Eingangssignal von sich.

"Hast du eventuell einen Screenshot?"
sehe ich zu, dass ich einen heranschaffe

"Beim PPM Summensignal wird die Zeit zwischen zwei gleichen Flanken gemessen.
Also normalerweise zwischen den fallenden Flanken, d.h. die Pulsbreite als solche ist egal. Meist ist die Pause konstant 390 us (Graupner/JR). So gesehn würden deine 1.9ms tatsächlich 2.29 ms bedeuten."

Das ist eine interessante Information. Ich frage mal dezidiert nach - die Zeit zwischen zwei gleichen Flanken gemessen - ist das bei Jeti so, oder allgemein? War mir auch aufgefallen, dass sich die Länge der inaktiven Pulszeiten empfangsseitig nicht geändert hat, egal was ich sendeseitig eingefüttert habe.

Hintergrund
Bin daran interessiert, weil ich auf den vorhandenen Kanälen virtuelle Kanäle über Multiplexing mache. Als "Start-of-Period-Token" würde ich am liebsten natürlich die Länge des passiven Signalteils beeinflussen. Wobei ich mich schon gefragt habe, ob der überhaupt übertragen wird. Macht im Prinzip auch keinen Sinn, da er als normaler Weise konstanter Teil nur auf die Bandbreite drückt.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Letzte Änderung: von Jasson.

Transmitter TU2 -> Problem mit Pulsdauern 06 Mai 2020 09:00 #5

  • IG-Modellbau
  • IG-Modellbaus Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Beiträge: 1227
  • Karma: 10
  • Dank erhalten: 655
Hallo Jasson,
zeige doch bitte mal einen Screenshot vom Impulstelegramm, da können noch andere Dinge inkorrekt sein.
Zeit von Puls zu Puls und die Frametime z.B.

Ingmar

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Transmitter TU2 -> Problem mit Pulsdauern 20 Mai 2020 08:25 #6

  • Jasson
  • Jassons Avatar Autor
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Beiträge: 5
  • Dank erhalten: 0
Ok, hab an einer anderen Stelle getüftelt und bin dabei drauf gestoßen, wo der Hase die Löffel hat.

Mir war nicht klar, dass der "inaktive" Teil des eines Kanalpulses mit in die Gesamtlänge eingeht. Also, dass die 400µs schon Teil der 1000 - 2000 ms sind.
Hatte ganz früher schon mal was eigenes auf ner MHz-Anlage gemacht und weil man da ohne digitale "Zwischenintelligenz" direkt auf dem physikalischen Kanal ist, hat das funktioniert. Hatte den Ansatz (400µs + 1500µs Neutral) dann unbewusst und dadurch ungeprüft übernommen.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

  • Seite:
  • 1
Ladezeit der Seite: 0.161 Sekunden
Powered by Kunena Forum