Esens - All in one Sensor für Elektrosegler

25 Nov 2017 10:58 - 25 Nov 2017 11:03 #7 von FuniCapi

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

25 Nov 2017 10:59 - 25 Nov 2017 11:17 #8 von FuniCapi
Und es geht nochmal weiter:
- Drahtbrücken
- Patchkabel
- Programmieradapter

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

28 Nov 2017 19:27 #9 von FuniCapi
Hallo zusammen

Eine erste ausführlichere Bauanleitung ist da. Ich habe versucht sie so zu gestalten dass auch Elektronikanfänger in der Lage sind den Esens aufzubauen.
Die Anleitung wird noch erweitert werden um die Kapitel Programierung und Einstellung/Kalibrierung.
Falls ihr Anregungen habt einfach melden.

Softwareseitig arbeite ich gerade an einer Innenwiderstandsmessung. Sobald ich diese erstmals getestet habe wird sie veröffentlicht.

Gruss Lukas
Anhang:
Folgende Benutzer bedankten sich: AlexBonfire, Ruedi, T.B.08

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

28 Nov 2017 21:43 - 28 Nov 2017 21:43 #10 von gerhardf1
hallo lukas,
tolle arbeit, danke dafür!

eine frage hätte ich zum arduino board:
Lässt sich ein 3,3V/8MHz board auch einsetzen?

gruss
gerhard

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

28 Nov 2017 22:01 #11 von FuniCapi
Ja, 3.3V geht auch, ausser der Pitot Sensor. Der ist für 5V ausgelegt. Evtl. gibts da noch andere Drucksensoren für 3.3V.
Die Spannungsteiler bei der Empfängerspannungserweiterung müssen angepasst werden von 1:2 auf 1:3 Teilungsverhältnis.
Das AttoPilot Voltage and Current Sense Breakout ist sogar genauer bei 3.3V, da für 3.3V ausgelegt.
Im Code muss die Zeile #define VCC 5.0 auf #define VCC 3.3 geändert werden, damit die Default Werte beim Rücksetzen richtig initialisiert werden.

Gruss Lukas

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

28 Nov 2017 22:11 #12 von gerhardf1
hallo lukas,
danke für deine prompte antwort.
ich habe in esens.ino VCC entsprechend angepasst und das ganze in ein arduino pro mini mit 3,3V/8MHz geladen. sensoren habe ich keine angeschlossen.
die jetibox zeigt nach einigen sekunden "communication error".
hast du da eine idee?

gruss
gerhard

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 0.118 Sekunden

Impressum