Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: Hilfe Jeti mit OmnibusF4

Hilfe Jeti mit OmnibusF4 13 Mai 2018 14:44 #31

  • AlexBonfire
  • AlexBonfires Avatar
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Beiträge: 1014
  • Karma: 5
  • Dank erhalten: 279
Ich habe jetzt einen Weg gefunden, der mit den vorhandenen Anschlüssen funzt:
Am R5 habe ich UDI an Servoausgang 5 eingestellt und im Betaflight Serieller Eingang + X-Bus.
Dann über den Eingang DSMX am Board verbunden - funktioniert, ohne Telemetrie natürlich.
Ist zwar kein Ex-Bus, aber immerhin ...

Ich werde eventuell noch ein kleines GPS und einen Stromsensor einbauen, dann muss ich ihn sowieso zerlegen. Ein guter Zeitpunkt um Ex-Bus an UART 3 oder 6 + Telemetrie noch einmal anzugehen.

Danke nochmal für die Hilfe :)

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Hilfe Jeti mit OmnibusF4 13 Mai 2018 14:50 #32

  • Roady123
  • Roady123s Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Beiträge: 315
  • Karma: 2
  • Dank erhalten: 65
Das habe ich so auch noch nicht gesehen aber gut zu wissen.
Danke für die Rückmeldung.

Gruß Christoph

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Hilfe Jeti mit OmnibusF4 12 Jun 2019 01:05 #33

  • ThLehmann
  • ThLehmanns Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Beiträge: 261
  • Karma: 4
  • Dank erhalten: 86
Hole das Thema mal aus der Versenkung da ich gerade vor dem gleichen Problem stehe.
Habe einen HGLRC XJB-145 Race Copter mit dem von Alex in #24 verlinkten FC / Stack und aktuellem Betaflight 4.0.3. Als Empfänger einen R7nano.
Die Übertragung per PPM bekomme ich hin, eine digitale per UDI / EXBUS aber nicht. Auch die Kombi mit DSMX wie in #30 dargestellt klappt nicht.

Der SBUS Anschluss am FC ist invertiert, dann pieps der Bindemode.

Bin jetzt am Ende und verstehe nicht wo das Problem liegt. Auf Telemetrie kann ich verzichten, aber digital (UDI / EXBUS) übertragen würde ich schon gerne.
Gibt es ggf. schon eine Lösung ?
immer schön vorsichtig landen
Gruß, Thomas

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Hilfe Jeti mit OmnibusF4 12 Jun 2019 09:29 #34

  • ThLehmann
  • ThLehmanns Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Beiträge: 261
  • Karma: 4
  • Dank erhalten: 86
habs jetzt hinbekommen :)

Laut Board Beschreibung ist der UART1 für serielle Empfänger, dort habe ich aber keinen TX1 gefunden. So vermute ich das der UART1 nur den RX Pin auf SBUS/DSMX/PPM gelegt hat.
Auf der Boardunterseite befindet sich dann noch UART3+6, TX3 ist belegt und geht zum VTX, RX6/TX6 ist noch frei. Jeti EXBUS auf TX6 gelegt, im BF konfiguriert und siehe da, es läuft.
Schade da ich mir schon einen Mini GPS geordert habe und diesen eigtl. an UART6 anschliessen wollte.

Beim GPS wird ja nur der RX benötigt, ein Mischbetrieb mit dem freien RX3 vom VTX oder RX6 dürfte nicht möglich sein, oder ?
Wenn jetzt jemand einen Tipp hat wo ich TX1 finde oder wie ich GPS anschliessen kann ...
immer schön vorsichtig landen
Gruß, Thomas

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Letzte Änderung: von ThLehmann.

Hilfe Jeti mit OmnibusF4 12 Jun 2019 18:33 #35

  • OpaMichi
  • OpaMichis Avatar
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Beiträge: 52
  • Dank erhalten: 3
Hast Du den UART2 noch frei?

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Hilfe Jeti mit OmnibusF4 12 Jun 2019 19:40 #36

  • Roady123
  • Roady123s Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Beiträge: 315
  • Karma: 2
  • Dank erhalten: 65
Laut Manual gibt es nur UART1 + 3 + 6 zur freien Verwendung
Das mit dem Mischbetrieb habe ich auch schonm mal mit nem andern Board versucht habe es aber nicht hin bekommen.

Gruß Christoph

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Letzte Änderung: von Roady123.
Moderatoren: Malte
Ladezeit der Seite: 0.184 Sekunden
Powered by Kunena Forum