Openxsensor Troubleshooting

31 Okt 2017 18:41 #91 von VOBO
Nur noch als Ergänzung zu meinem letzten Beitrag:

Es hatte sich ein Fehler eingeschlichen, den ich inzwischen behoben habe.
Resistor to Voltage war an der falschen Position.
Falls das jemandem auffällt, bitte ignorieren.

Das hatte mit dem geschilderten Problem aber nichts zu tun, nach wie vor vorhanden.

Gruß Volker

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

06 Nov 2017 16:27 #92 von onki
Hallo zusammen,

es gibt eine neue OXS-Version in der offenbar speziell Fehler hinsichtlich Jeti (Spannungsmessung) behoben wurden.
github.com/openXsensor/openXsensor/commi...b0f38e9fde4cd1684766

Gruß
Onki

Gruß aus dem Nordschwarzwald
Rainer aka Onki
www.onki.de
gepostet unter Verwendung von 100% recycelter Elektronen.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

07 Nov 2017 08:33 #93 von VOBO

VOBO schrieb: So, habe jetzt auch noch ein Mysterium aufzuklären.
Mein Stromsensor läuft ja nun schon super über den Eingang A7.

Jetzt möchte ich noch die Flugakku-Spannung messen. Dafür habe ich Eingang A6 ausgewählt.

Die Eingänge A4 und A5 sind ja für das Vario (kommt noch) reserviert und die Eingänge A0-A3 möchte ich für eine zukünftige Einzelzellen-Messung reservieren (max.4S).

Leider bekomme ich es nicht hin, das der Eingang A6 von der DS14 angezeigt/erkannt wird.
Was könnte da faul sein? Hänge mal die Screenshots mit den maßgeblichen Konfigurationen hier an.

In einem erstem Modul habe ich ein Vario und eine Empfängerspannungsmesseung an Eingang A0 (Volt_1) erfolgreich hinbekommen.

Ich habe daher hier mal testweise anstatt A6(Volt_5) mal A0(Volt_1) versucht und damit geht es.
Für mich sieht das erst mal so aus als wenn bei Jeti ausschließlich Volt_1 verwendet werden kann um abseits von Einzelzellenüberwachung eine zusätzliche Spannung zu messen.
Das beißt sich natürlich dann, wenn die Einselzellenmessung auf A0-A3 kommt.

Eigentlich sollte ja laut Beschreibung jeder Eingang (Volt_1.....Volt_6) konfigurierbar sein.

Wäre nett wenn sich mal ein Wissender dazu äußern kann.











Gruß Volker



So, ich habe den Fehler gefunden und mstrens hat ein Fix herausgegeben.
Ich habe aber noch weitere Änderungswünsche/Fehlerbeseitigungen angemeldet, ich denke da kommt in Kürze noch ein Update.

Gruß Volker

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

14 Nov 2017 09:12 - 14 Nov 2017 09:15 #94 von onki
Hallo,

ich habe gestern angefangen den OxS Sensor für meine neue FunCub XL zu erstellen mit GPS, BMP280 Höhenanzeige (is besser als Assist freischalten :evil: ) und einem Sequencer für ACL, Beacon, Posilampen und Landelicht (Signalgenerator für LED-Treiber).
Dabei fiel mir auf, dass mit der aktuellsten Version keine GPS-Daten im Sender angezeigt werden. Das GPS-Modul liefert mit der ublox Software aber valide Daten.

Hat jemand ähnliches beobachtet?
Es ist echt komisch. Beim Sequencer funktioniert die Dekodierung des Servosignals zur Ansteuerung des Sequencer in bestimmten Knüppelstellungen. Zum Reset der Füllstände bei einem Flowmeter konnte ich das Servosignal aber noch nicht nutzen. Da passiert rein gar nix. Auch der Pushbutoon funzt ned zum reset. Das dabei der Sequencer natürlich deaktiviert werden muss ist klar.

Vielleicht steigt dort ja mal jemand ein, der sich mehr in Richtung Jeti einbringt. Oder man forkt das Ganze. Ich bin da leider der Falsche. Ich freu mich schon wenn ich richtig mit den Konfigdateien umgehe. Einzig das Handling der verschiedenen Konfigurationsdateien bei einer neuen Version ist etwas umständlich. Hier wäre eine schlaue Lösung gefragt, die bestehende Configdaten "updatet" sofern sich daran strukturell was ändert. Bisher kopiere ich funktionierende Dateien in einen Unterordner. Im Fall einer neuen Version muss ich die aber i.d.R. neu gestalten.

Gruß
Onki

Gruß aus dem Nordschwarzwald
Rainer aka Onki
www.onki.de
gepostet unter Verwendung von 100% recycelter Elektronen.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

15 Jan 2018 21:58 #95 von MxK
Hallo Zusammen,

bin noch relativ jungfräulich, was das Thema OpenXsensoren angeht...

Habe folges Problem:
Wenn ich die Software auf das Arduino hochladen will bekomm ich diese Fehlermeldung:

Der Sketch verwendet 12090 Bytes (84%) des Programmspeicherplatzes. Das Maximum sind 14336 Bytes.
Globale Variablen verwenden 896 Bytes (87%) des dynamischen Speichers, 128 Bytes für lokale Variablen verbleiben. Das Maximum sind 1024 Bytes.
Wenig Arbeitsspeicher verfügbar, es können Stabilitätsprobleme auftreten.
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00
Problem beim Hochladen auf das Board. Hilfestellung dazu unter www.arduino.cc/en/Guide/Troubleshooting#upload .

Hat jemand ne Idee?

Danke Euch!


Gruß

Max

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

22 Jan 2018 08:53 #96 von MxK
So, Fehler "gefunden"...

Das Board ist offensichtlich defekt, hab ein anderes genommen, schon geht's problemlos!


Gruß

Max

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Ladezeit der Seite: 0.456 Sekunden

Impressum